28 June 2011

Life with GIMP 2.7

Trying to repair the ugly "Could not find compatible GRE between version 5.0 and 5.0." error after a Firefox 5 upgrade I did the mistake to run a full "yum update" which (so I deserve for having many repos enabled) brought me with GIMP 2.7.1, which I consciously downgraded from many months ago (2.7.2 is not available for F14). I have work to do: edit photos, not install/uninstall and downgrade apps again, so here are the first things I did trying to make GIMP 2.7 bearable:

  • change the "Export..." from Ctrl+Shift+E to Ctrl+S: I edit JPEGs and want to save JPEGs, not create from scratch to need XCFs (2.7 allow you to "Save" only in XCF, everything else is supposed to be exported);
  • changed the shortcut for "Fit Image to Window" from Ctrl+Shift+J back to Ctrl+Shift+E (as it used to be in 2.6): with image surgery you need to zoom a lot, and do that only one handed, the other hand holds the mouse;
  • disabled the confirmatin for closing unsaved images, since it is triggered even when the image was saved as JPEG, my desired target - hope won't lose data due to it.
Now back to work, will try to use it as it for the rest of the day and see how I can adjust to the new brushed, which dynamically change size (very annoying when you need precise size for image surgery) and force you to play with the brush scale on a tiny slider.
Wish me luck and wait for some hot pics on my photography blog later today (hopefully, if GIMP cooperates).

Update: in the end I created a set of custom fuzzy round brushes at various sizes: 3, 5, 9, 15, 19, 25 and use those, the slider is not usable to adjust the size. Hmmm... the GIMP developers are going to great lengths to remove useful functionality left and right, like they are aiming for inclusion into GNOME... newsflash for them: ain't gonna happen, these GNOME is not aimed at such advanced users like those able to edit pictures.


  1. Hi Nicu,
    Could you try to install Gimp 2.7.2 from f14? You will need to install both babl and gegl. Thanks.

  2. Luya: do you mean "from f15"? there is no 2.7.2 for f14, neither in updates, nor in your repo

  3. My f14 repo is updated with an attempt to backport gimp 2.7.2 so I would like to see if that work for you. =)

  4. something is wrong here:

    [root@hell ~]# rpm -q gimp
    [root@hell ~]# yum --enablerepo=fedora-gimp update gimp
    Loaded plugins: langpacks, presto, refresh-packagekit
    Adding en_US to language list
    Setting up Update Process
    No Packages marked for Update

  5. Manually update from

    You will need to install newer babl and gegl from that repository.

  6. that was one of the first things I tried, downloaded the rpms and ran an old fashioned "rpm -Uhv *". surprised to see "fc15" dependencies are needed when i install "fc14" packages.

    [root@hell gimp]# rpm -Uhv *
    error: Failed dependencies:
    libumfpack.so.5 is needed by gegl-0.1.6-2.fc15.i686
    libpoppler-glib.so.6 is needed by gimp-2:2.7.2-1.fc15.i686
    libpoppler.so.13 is needed by gimp-2:2.7.2-1.fc15.i686